Easy Pygame (ACSE Conference, February 2018, Sam Scott @ Mohawk College)

Setting Up

Participants should bring their own computer with Python 3.2.5 and the compatible version of Pygame installed.

Installation Instructions

Teach Easy Pygame

I will introduce the basics of mohawk_python.py and discuss how it can be integrated into an introductory programming course, and how it can be used to inspire novice programmers to create games and animations.

Workshop Materials

More Python and Pygame

This is a shortened and simplified version of a longer set of workshops I presented in 2016 on Python and Pygame. If you want more about Python and raw (not "easy") Pygame, the materials are all still there.

Python 2016 Materials